logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

meck-0.9.2.ebuild (638B)


  1. # Copyright 1999-2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit rebar3
  5. DESCRIPTION="Mocking library for Erlang"
  6. HOMEPAGE="https://github.com/eproxus/meck"
  7. SRC_URI="https://github.com/eproxus/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="Apache-2.0"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
  11. IUSE="test"
  12. RESTRICT="!test? ( test )"
  13. DEPEND="
  14. >=dev-lang/erlang-17.1
  15. test? ( dev-erlang/unite )
  16. "
  17. RDEPEND="${DEPEND}"
  18. DOCS=( CHANGELOG.md NOTICE README.md )
  19. src_prepare() {
  20. rebar3_src_prepare
  21. sed -i 's;{deps, \[unite\]},;{deps, []},;' rebar.config || die
  22. }