logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

plug-1.6.1.ebuild (677B)


  1. # Copyright 2019 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit mix
  5. MIX_REWRITE=true
  6. DESCRIPTION="specification and conveniences for composable modules between web applications"
  7. HOMEPAGE="https://github.com/elixir-plug/plug"
  8. LICENSE="Apache-2.0"
  9. SLOT="$(ver_cut 1-2)"
  10. SRC_URI="https://github.com/elixir-plug/plug/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  11. KEYWORDS="~amd64 ~arm ~arm64 ~x86"
  12. IUSE="telemetry doc"
  13. DEPEND="
  14. dev-elixir/hex
  15. >=dev-elixir/mime-1.0
  16. >=dev-elixir/plug_crypto-1.0
  17. telemetry? ( >=dev-elixir/telemetry-0.4 )
  18. doc? ( >=dev-elixir/ex_doc-0.19.1 )
  19. "
  20. RDEPEND="${DEPEND}"