logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

phoenix-1.4.9.ebuild (849B)


  1. # Copyright 2019 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit mix
  5. MIX_REWRITE="true"
  6. DESCRIPTION="productive web framework that does not compromise speed or maintainability"
  7. HOMEPAGE="https://github.com/phoenixframework/phoenix"
  8. LICENSE="MIT"
  9. SLOT="$(ver_cut 1-2)"
  10. SRC_URI="https://github.com/phoenixframework/phoenix/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  11. KEYWORDS="~amd64"
  12. IUSE="doc json test"
  13. RESTRICT="!test? ( test )"
  14. DEPEND="
  15. || (
  16. dev-elixir/plug:1.8
  17. dev-elixir/plug:1.9
  18. )
  19. >=dev-erlang/telemetry-0.4
  20. dev-elixir/phoenix_pubsub:1.1
  21. json? ( dev-elixir/jason:1.0 )
  22. doc? (
  23. dev-elixir/ex_doc:0.20
  24. dev-elixir/inch_ex:0.2
  25. )
  26. test? (
  27. dev-elixir/gettext:0.15
  28. dev-elixir/phoenix_html:2.11
  29. dev-elixir/websocket_client
  30. )
  31. "
  32. RDEPEND="${DEPEND}"