logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

linkify-9999.ebuild (704B)


  1. # Copyright 2019 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit mix
  5. DESCRIPTION="basic package for turning website names into links"
  6. HOMEPAGE="https://git.pleroma.social/pleroma/linkify"
  7. if [[ "${PV}" == "9999" ]]; then
  8. inherit git-r3
  9. EGIT_REPO_URI="https://git.pleroma.social/pleroma/linkify"
  10. else
  11. SRC_URI="https://git.pleroma.social/pleroma/linkify/-/archive/v${PV}/linkify-v${PV}.tar.bz2"
  12. KEYWORDS="~amd64 ~arm ~arm64 ~x86"
  13. fi
  14. SLOT="$(ver_cut 1-2)"
  15. LICENSE="MIT"
  16. IUSE="test doc"
  17. RESTRICT="!test? ( test )"
  18. DEPEND="
  19. test? ( >=dev-elixir/credo-1.1.0 )
  20. doc? ( >=dev-elixir/ex_doc-0.20 )
  21. "
  22. RDEPEND="${DEPEND}"