logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

jose-1.8.4.ebuild (856B)


  1. # Copyright 2019 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit mix
  5. DESCRIPTION="JSON Object Signing and Encryption (JOSE) for Erlang and Elixir"
  6. HOMEPAGE="https://github.com/potatosalad/erlang-jose"
  7. LICENSE="MIT"
  8. SLOT="$(ver_cut 1-2)"
  9. SRC_URI="https://github.com/potatosalad/erlang-jose/archive/${PV}.tar.gz -> ${P}.tar.gz"
  10. KEYWORDS="~amd64 ~arm ~arm64 ~x86"
  11. IUSE="test doc"
  12. RESTRICT="!test? ( test )"
  13. DEPEND="
  14. dev-elixir/hex
  15. >=dev-erlang/base64url-0.0.1
  16. test? (
  17. dev-elixir/cutkey
  18. >=dev-elixir/jsone-1.4
  19. >=dev-elixir/jsx-2.8
  20. >=dev-elixir/libdecaf-0.0.4
  21. >=dev-elixir/libsodium-0.0.10
  22. >=dev-elixir/ojson-1.0
  23. >=dev-elixir/poison-3.1
  24. )
  25. doc? (
  26. >=dev-elixir/ex_doc-0.15
  27. >=dev-elixir/earkmark-1.2
  28. )
  29. "
  30. RDEPEND="${DEPEND}"
  31. S="${WORKDIR}/erlang-${P}"