logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

hex-0.20.6.ebuild (726B)


  1. # Copyright 2019-2021 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit mix
  5. DESCRIPTION=""
  6. HOMEPAGE="https://github.com/hexpm/hex"
  7. LICENSE="Apache-2.0"
  8. SLOT="$(ver_cut 1-2)"
  9. SRC_URI="https://github.com/hexpm/hex/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  10. KEYWORDS="~amd64"
  11. IUSE="test"
  12. RESTRICT="!test? ( test )"
  13. # Require >=elixir-1.5.0 because of the dependencies differencies between the two
  14. DEPEND="
  15. test? (
  16. >=dev-lang/elixir-1.5.0
  17. =dev-elixir/stream_data-0.4.0
  18. =dev-elixir/plug-1.6.1
  19. =dev-elixir/mime-1.3.0
  20. dev-elixir/bypass
  21. =dev-elixir/cowboy-1.0.4
  22. =dev-elixir/cowlib-1.0.2
  23. =dev-elixir/ranch-1.2.1
  24. )
  25. "
  26. RDEPEND="${DEPEND}"