logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

nuget-5.0.2.ebuild (573B)


  1. # Copyright 1999-2018 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. # See https://dist.nuget.org/index.json for available versions
  5. DESCRIPTION="Nuget - .NET Package Manager"
  6. HOMEPAGE="https://www.nuget.org/"
  7. SRC_URI="https://dist.nuget.org/win-x86-commandline/v${PV}/nuget.exe -> ${P}.exe"
  8. LICENSE="Apache-2.0"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE=""
  12. S="${WORKDIR}"
  13. src_compile() { :; }
  14. src_install() {
  15. exeinto "/usr/bin"
  16. doexe "${FILESDIR}/nuget"
  17. insinto "/usr/lib/${PN}"
  18. newins "${DISTDIR}/${P}.exe" "nuget.exe"
  19. }