logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

timescaledb-1.2.1.ebuild (920B)


  1. # Copyright 1999-2018 Gentoo Authors
  2. # Copyright 2018-2019 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  3. # Distributed under the terms of the GNU General Public License v2
  4. EAPI=6
  5. POSTGRES_COMPAT=( 9.6 10 )
  6. POSTGRES_USEDEP="server"
  7. inherit postgres-multi
  8. DESCRIPTION="A time-series database optimized for fast ingest and complex queries"
  9. HOMEPAGE="https://www.timescale.com/"
  10. SRC_URI="https://github.com/timescale/${PN}/releases/download/${PV}/${P}.tar.gz"
  11. LICENSE="Apache-2.0"
  12. SLOT="0"
  13. IUSE="static-libs"
  14. KEYWORDS="~amd64 ~x86"
  15. DEPEND="${POSTGRES_DEP}"
  16. RDEPEND="${DEPEND}"
  17. S="${WORKDIR}/${PN}"
  18. src_prepare() {
  19. default
  20. postgres-multi_src_prepare
  21. }
  22. src_configure() {
  23. postgres-multi_foreach cmake-utils_src_configure
  24. }
  25. src_compile() {
  26. postgres-multi_foreach cmake-utils_src_compile
  27. }
  28. src_install() {
  29. postgres-multi_foreach cmake-utils_src_install
  30. use static-libs || find "${ED}" -name '*.a' -delete
  31. }