logo

overlay

My (experimental) gentoo overlay

timescaledb-0.12.1.ebuild (866B)


      1 # Copyright 1999-2018 Gentoo Foundation
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=6
      5 
      6 POSTGRES_COMPAT=( 9.6 10 )
      7 POSTGRES_USEDEP="server"
      8 
      9 inherit cmake-utils postgres-multi
     10 
     11 DESCRIPTION="A time-series database optimized for fast ingest and complex queries"
     12 HOMEPAGE="http://www.timescale.com/"
     13 SRC_URI="https://github.com/timescale/${PN}/releases/download/${PV}/${P}.tar.gz"
     14 
     15 LICENSE="Apache-2.0"
     16 SLOT="0"
     17 IUSE="static-libs"
     18 KEYWORDS="~amd64 ~x86"
     19 
     20 DEPEND="
     21 	${POSTGRES_DEP}
     22 "
     23 RDEPEND="${DEPEND}"
     24 
     25 S=${WORKDIR}/${PN}
     26 
     27 src_prepare() {
     28 	eapply_user
     29 	postgres-multi_src_prepare
     30 }
     31 src_configure() {
     32 	postgres-multi_foreach cmake-utils_src_configure
     33 }
     34 
     35 src_compile() {
     36 	postgres-multi_foreach cmake-utils_src_compile
     37 }
     38 
     39 src_install() {
     40 	postgres-multi_foreach cmake-utils_src_install
     41 
     42 	use static-libs || find "${ED}" -name '*.a' -delete
     43 }