logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

vis-ctags-9999.ebuild (576B)


  1. # Copyright 2021 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit git-r3
  5. DESCRIPTION="vis plugin to provide basic ctags support"
  6. HOMEPAGE="https://github.com/kupospelov/vis-ctags"
  7. EGIT_REPO_URI="https://github.com/kupospelov/vis-ctags"
  8. LICENSE="MIT"
  9. SLOT="0"
  10. RDEPEND="
  11. dev-util/ctags
  12. >=app-editors/vis-0.7[lua]
  13. "
  14. src_install() {
  15. einstalldocs
  16. insinto /usr/share/vis/
  17. doins ctags.lua
  18. }
  19. pkg_install() {
  20. einfo "Add require('ctags') to your vis configuration to enable ctags support"
  21. }