logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

hoedown-9999.ebuild (787B)


  1. # Copyright 1999-2020 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit toolchain-funcs
  5. if [[ ${PV} == "9999" ]]; then
  6. inherit git-r3
  7. EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
  8. else
  9. SRC_URI="https://github.com/hoedown/hoedown/archive/${PV}.tar.gz -> ${P}.tar.gz"
  10. KEYWORDS="~amd64 ~x86"
  11. fi
  12. DESCRIPTION="Standards compliant, fast, secure markdown processing library in C"
  13. HOMEPAGE="https://github.com/hoedown/hoedown"
  14. LICENSE="ISC"
  15. SLOT="0"
  16. IUSE="test"
  17. RDEPEND="!dev-python/smartypants"
  18. DEPEND="
  19. ${RDEPEND}
  20. test? ( app-text/htmltidy )
  21. "
  22. src_compile() {
  23. emake \
  24. CC=$(tc-getCC) \
  25. CFLAGS="${CFLAGS}"
  26. }
  27. src_install() {
  28. emake \
  29. PREFIX=/usr \
  30. LIBDIR=/usr/$(get_libdir) \
  31. DESTDIR="${D}" \
  32. install
  33. einstalldocs
  34. }