logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

grammalecte-2.1.1.ebuild (745B)


  1. # Copyright 2023 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. PYTHON_COMPAT=( python3_{8..11} )
  5. DISTUTILS_SINGLE_IMPL=1
  6. DISTUTILS_USE_PEP517=setuptools
  7. inherit distutils-r1
  8. DESCRIPTION="Correcteur grammatical et typographique open source dédié à la langue française"
  9. HOMEPAGE="https://grammalecte.net/"
  10. SRC_URI="https://grammalecte.net/zip/Grammalecte-fr-v${PV}.zip"
  11. S="${WORKDIR}/"
  12. LICENSE="GPL-3"
  13. SLOT="0"
  14. KEYWORDS="~amd64"
  15. IUSE=""
  16. RDEPEND="$(python_gen_cond_dep 'dev-python/bottle[${PYTHON_USEDEP}]')"
  17. DEPEND="${RDEPEND}"
  18. src_prepare() {
  19. rm grammalecte/bottle.py || die
  20. sed -i -e 's;grammalecte.bottle;bottle;' grammalecte-server.py || die
  21. default
  22. }