logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

evince-3.34.2.ebuild (3151B)


  1. # Copyright 1999-2019 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. GNOME2_LA_PUNT="yes"
  5. GNOME2_EAUTORECONF="yes"
  6. inherit gnome2 systemd
  7. DESCRIPTION="Simple document viewer for GNOME"
  8. HOMEPAGE="https://wiki.gnome.org/Apps/Evince"
  9. LICENSE="GPL-2+ CC-BY-SA-3.0"
  10. # subslot = evd3.(suffix of libevdocument3)-evv3.(suffix of libevview3)
  11. SLOT="0/evd3.4-evv3.3"
  12. IUSE="dbus djvu dvi gstreamer gnome gnome-keyring +introspection nautilus nsplugin postscript spell t1lib tiff xps"
  13. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
  14. # atk used in libview
  15. # bundles unarr
  16. COMMON_DEPEND="
  17. dev-libs/atk
  18. >=dev-libs/glib-2.36:2[dbus?]
  19. >=dev-libs/libxml2-2.5:2
  20. sys-libs/zlib:=
  21. >=x11-libs/gdk-pixbuf-2.36.5:2
  22. >=x11-libs/gtk+-3.22.0:3[introspection?]
  23. gnome-base/gsettings-desktop-schemas
  24. >=x11-libs/cairo-1.10:=
  25. >=app-text/poppler-0.33[cairo]
  26. >=app-arch/libarchive-3.2.0
  27. djvu? ( >=app-text/djvu-3.5.22:= )
  28. dvi? (
  29. virtual/tex-base
  30. dev-libs/kpathsea:=
  31. t1lib? ( >=media-libs/t1lib-5:= ) )
  32. gstreamer? (
  33. media-libs/gstreamer:1.0
  34. media-libs/gst-plugins-base:1.0
  35. media-libs/gst-plugins-good:1.0 )
  36. gnome? ( gnome-base/gnome-desktop:3= )
  37. gnome-keyring? ( >=app-crypt/libsecret-0.5 )
  38. introspection? ( >=dev-libs/gobject-introspection-1:= )
  39. nautilus? ( >=gnome-base/nautilus-2.91.4 )
  40. postscript? ( >=app-text/libspectre-0.2:= )
  41. spell? ( >=app-text/gspell-1.6.0:= )
  42. tiff? ( >=media-libs/tiff-3.6:0= )
  43. xps? ( >=app-text/libgxps-0.2.1:= )
  44. "
  45. RDEPEND="${COMMON_DEPEND}
  46. dbus? ( gnome-base/gvfs )
  47. gnome-base/librsvg
  48. || (
  49. >=x11-themes/adwaita-icon-theme-2.17.1
  50. >=x11-themes/hicolor-icon-theme-0.10 )
  51. "
  52. DEPEND="${COMMON_DEPEND}
  53. app-text/docbook-xml-dtd:4.3
  54. dev-util/gdbus-codegen
  55. dev-util/glib-utils
  56. >=dev-util/gtk-doc-am-1.13
  57. >=dev-util/intltool-0.35
  58. dev-util/itstool
  59. sys-devel/gettext
  60. virtual/pkgconfig
  61. app-text/yelp-tools
  62. "
  63. # eautoreconf needs:
  64. # app-text/yelp-tools
  65. PATCHES=(
  66. "${FILESDIR}"/3.30.2-internal-synctex.patch # don't automagically link to synctex from texlive-core - always use internal copy of this small parser for now; requires eautoreconf
  67. )
  68. src_prepare() {
  69. gnome2_src_prepare
  70. # Do not depend on adwaita-icon-theme, bug #326855, #391859
  71. # https://gitlab.freedesktop.org/xdg/default-icon-theme/issues/7
  72. sed -e 's/adwaita-icon-theme >= $ADWAITA_ICON_THEME_REQUIRED//g' \
  73. -i configure || die "sed failed"
  74. }
  75. src_configure() {
  76. gnome2_src_configure \
  77. --disable-static \
  78. --enable-pdf \
  79. --enable-comics \
  80. --enable-thumbnailer \
  81. --with-platform=gnome \
  82. $(use_enable dbus) \
  83. $(use_enable djvu) \
  84. $(use_enable dvi) \
  85. $(use_enable gstreamer multimedia) \
  86. $(use_enable gnome libgnome-desktop) \
  87. $(use_with gnome-keyring keyring) \
  88. $(use_enable introspection) \
  89. $(use_enable nautilus) \
  90. $(use_enable nsplugin browser-plugin) \
  91. $(use_enable postscript ps) \
  92. $(use_with spell gspell) \
  93. $(use_enable t1lib) \
  94. $(use_enable tiff) \
  95. $(use_enable xps) \
  96. BROWSER_PLUGIN_DIR="${EPREFIX}"/usr/$(get_libdir)/nsbrowser/plugins \
  97. --with-systemduserunitdir="$(systemd_get_userunitdir)"
  98. }