logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

mksh-9999.ebuild (1088B)


  1. # Copyright 1999-2019 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit eutils toolchain-funcs
  5. if [[ $PV = 9999 ]]; then
  6. inherit cvs
  7. ECVS_SERVER="anoncvs.mirbsd.org:/cvs"
  8. ECVS_MODULE="mksh"
  9. ECVS_USER="_anoncvs"
  10. ECVS_AUTH="ext"
  11. KEYWORDS=""
  12. else
  13. SRC_URI="https://www.mirbsd.org/MirOS/dist/mir/mksh/${PN}-R${PV}.tgz"
  14. KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
  15. fi
  16. DESCRIPTION="MirBSD Korn Shell"
  17. HOMEPAGE="http://mirbsd.de/mksh"
  18. LICENSE="BSD"
  19. SLOT="0"
  20. IUSE="static +lksh"
  21. RDEPEND=""
  22. S="${WORKDIR}/${PN}"
  23. src_compile() {
  24. tc-export CC
  25. if use static; then export LDSTATIC="-static"; fi
  26. export CPPFLAGS="${CPPFLAGS} -DMKSH_DEFAULT_PROFILEDIR=\\\"${EPREFIX}/etc\\\""
  27. # Note: lksh should be used as a replacement to /bin/sh instead of mksh
  28. if use lksh
  29. then
  30. export CPPFLAGS="${CPPFLAGS} -DMKSH_BINSHPOSIX -DMKSH_BINSHREDUCED"
  31. sh Build.sh -r -L || die
  32. fi
  33. sh Build.sh -r || die
  34. }
  35. src_install() {
  36. exeinto /bin
  37. use lksh && doexe lksh
  38. doexe mksh
  39. doman mksh.1
  40. dodoc dot.mkshrc
  41. }
  42. src_test() {
  43. ./test.sh -v || die
  44. }