logo

overlay

My (experimental) gentoo overlay

todoman-3.4.0.ebuild (1330B)


      1 # Copyright 1999-2018 Gentoo Foundation
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI="6"
      5 
      6 PYTHON_COMPAT=(python{3_4,3_5,3_6})
      7 
      8 inherit distutils-r1 bash-completion-r1
      9 
     10 DESCRIPTION="A simple CalDav-based todo manager"
     11 HOMEPAGE="https://github.com/pimutils/todoman"
     12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
     13 
     14 LICENSE="ISC"
     15 KEYWORDS="~amd64 ~x86"
     16 SLOT="0"
     17 IUSE="bash-completion test repl zsh-completion"
     18 
     19 RDEPEND=">=dev-python/click-6.0[${PYTHON_USEDEP}]
     20 	dev-python/atomicwrites[${PYTHON_USEDEP}]
     21 	dev-python/humanize[${PYTHON_USEDEP}]
     22 	dev-python/icalendar[${PYTHON_USEDEP}]
     23 	dev-python/urwid[${PYTHON_USEDEP}]
     24 	dev-python/pyxdg[${PYTHON_USEDEP}]
     25 	dev-python/parsedatetime[${PYTHON_USEDEP}]
     26 	dev-python/tabulate[${PYTHON_USEDEP}]
     27 	dev-python/configobj[${PYTHON_USEDEP}]
     28 	dev-python/python-dateutil[${PYTHON_USEDEP}]
     29 	>=dev-python/click-log-0.2.1[${PYTHON_USEDEP}]
     30 	repl? ( dev-python/click-repl[${PYTHON_USEDEP}] )"
     31 
     32 DEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]
     33 	test? ( dev-python/pytest-runner[${PYTHON_USEDEP}] )"
     34 
     35 DOCS=( docs/source/contributing.rst README.rst todoman.conf.sample )
     36 
     37 src_install() {
     38 	distutils-r1_src_install
     39 
     40 	dobashcomp contrib/completion/bash/_todo
     41 
     42 	if use zsh-completion; then
     43 		insinto /usr/share/zsh/site-functions
     44 		doins contrib/completion/zsh/_todo
     45 	fi
     46 }