logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

binwalk-2.1.1-r2.ebuild (1189B)


  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Copyright 2018-2019 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  3. # Distributed under the terms of the GNU General Public License v2
  4. EAPI=7
  5. PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
  6. inherit distutils-r1
  7. if [[ ${PV} == "9999" ]] ; then
  8. EGIT_REPO_URI="https://github.com/ReFirmLabs/binwalk.git"
  9. inherit git-r3
  10. else
  11. SRC_URI="https://github.com/ReFirmLabs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  12. KEYWORDS="~amd64 ~x86"
  13. fi
  14. DESCRIPTION="A tool for identifying files embedded inside firmware images"
  15. HOMEPAGE="https://github.com/ReFirmLabs/binwalk"
  16. LICENSE="MIT"
  17. SLOT="0"
  18. IUSE="graph jffs2 squashfs"
  19. RDEPEND="
  20. $(python_gen_cond_dep 'dev-python/backports-lzma[${PYTHON_USEDEP}]' python2_7)
  21. graph? ( dev-python/pyqtgraph[opengl,${PYTHON_USEDEP}] )
  22. squashfs? (
  23. sys-fs/squashfs-tools:0
  24. sys-fs/sasquatch
  25. )
  26. jffs2? ( app-arch/jefferson )
  27. dev-libs/capstone[python]
  28. sys-fs/mtd-utils
  29. app-arch/arj
  30. app-arch/p7zip
  31. app-arch/cabextract
  32. sys-fs/cramfs
  33. "
  34. PATCHES=( "${FILESDIR}"/0001-Added-check-for-backports.lzma-when-importing-lzma-m.patch )
  35. python_install_all() {
  36. local DOCS=( API.md README.md )
  37. distutils-r1_python_install_all
  38. }