logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

unicode-data-13.0.0.ebuild (790B)


  1. # Copyright 1999-2020 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. DESCRIPTION="Unicode data from unicode.org"
  5. HOMEPAGE="https://www.unicode.org/ucd/"
  6. SRC_URI="https://www.unicode.org/Public/zipped/${PV}/UCD.zip -> ${P}-UCD.zip
  7. https://www.unicode.org/Public/zipped/${PV}/Unihan.zip -> ${P}-Unihan.zip"
  8. LICENSE="unicode"
  9. SLOT="0"
  10. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
  11. IUSE=""
  12. DEPEND="app-arch/unzip"
  13. RDEPEND=""
  14. S="${WORKDIR}"
  15. src_unpack() {
  16. # Unihan.zip needs to be installed as a zip for reverse deps
  17. # https://bugzilla.gnome.org/show_bug.cgi?id=768210
  18. unpack ${P}-UCD.zip
  19. }
  20. src_install() {
  21. insinto /usr/share/${PN}
  22. doins -r "${S}"/*
  23. newins "${DISTDIR}"/${P}-Unihan.zip Unihan.zip
  24. }