logo

overlay

My own overlay for experimentations, use with caution, no support is provided

unicode-data-12.0.0.ebuild (837B)


      1 # Copyright 1999-2018 Gentoo Foundation
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=6
      5 
      6 DESCRIPTION="Unicode data from unicode.org"
      7 HOMEPAGE="https://www.unicode.org/ucd/"
      8 SRC_URI="https://www.unicode.org/Public/zipped/${PV}/UCD.zip -> ${P}-UCD.zip
      9 	https://www.unicode.org/Public/zipped/${PV}/Unihan.zip -> ${P}-Unihan.zip"
     10 
     11 LICENSE="unicode"
     12 SLOT="0"
     13 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
     14 IUSE=""
     15 
     16 RESTRICT="mirror"
     17 
     18 DEPEND="app-arch/unzip"
     19 RDEPEND=""
     20 
     21 S="${WORKDIR}"
     22 
     23 src_unpack() {
     24 	# Unihan.zip needs to be installed as a zip for reverse deps
     25 	# https://bugzilla.gnome.org/show_bug.cgi?id=768210
     26 	unpack ${P}-UCD.zip
     27 }
     28 
     29 src_install() {
     30 	insinto /usr/share/${PN}
     31 	doins -r "${S}"/*
     32 	newins "${DISTDIR}"/${P}-Unihan.zip Unihan.zip
     33 }