logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

fcitx-5.0.23.ebuild (2467B)


  1. # Copyright 2021-2022 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit cmake xdg-utils
  5. DV="20121020"
  6. MY_PN="fcitx5"
  7. DESCRIPTION="Fcitx (Flexible Context-aware Input Tool with eXtension) input method framework"
  8. HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx5"
  9. SRC_URI="https://github.com/fcitx/fcitx5/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz
  10. https://download.fcitx-im.org/data/en_dict-${DV}.tar.gz -> fcitx-data-en_dict-${DV}.tar.gz"
  11. LICENSE="LGPL-2.1+"
  12. SLOT="5"
  13. KEYWORDS="~amd64 ~x86"
  14. IUSE="X coverage dbus doc +emoji +enchant +keyboard +libuuid +server systemd test wayland"
  15. REQUIRED_USE="coverage? ( test )"
  16. RESTRICT="!test? ( test )"
  17. DEPEND="
  18. X? (
  19. dev-libs/glib:2
  20. x11-libs/cairo[X]
  21. x11-libs/gdk-pixbuf:2
  22. x11-libs/libxcb[xkb]
  23. x11-libs/libxkbfile
  24. x11-libs/pango[X]
  25. ~x11-libs/xcb-imdkit-1.0.3
  26. x11-libs/xcb-util
  27. x11-libs/xcb-util-keysyms
  28. x11-libs/xcb-util-wm
  29. )
  30. dev-libs/libfmt
  31. emoji? (
  32. app-i18n/unicode-cldr
  33. dev-libs/expat
  34. )
  35. enchant? ( app-text/enchant:2 )
  36. keyboard? (
  37. app-text/iso-codes
  38. dev-libs/expat
  39. dev-libs/json-c
  40. x11-libs/libxkbcommon[X?]
  41. x11-misc/xkeyboard-config
  42. )
  43. libuuid? ( sys-apps/util-linux )
  44. sys-devel/gettext
  45. systemd? ( sys-apps/systemd )
  46. !systemd? (
  47. dbus? ( sys-apps/dbus )
  48. dev-libs/libevent
  49. )
  50. virtual/libintl
  51. wayland? (
  52. dev-libs/glib:2
  53. dev-libs/wayland
  54. dev-libs/wayland-protocols
  55. dev-util/wayland-scanner
  56. x11-libs/cairo
  57. x11-libs/gdk-pixbuf:2
  58. x11-libs/pango
  59. )
  60. "
  61. RDEPEND="${DEPEND}
  62. "
  63. BDEPEND="
  64. doc? ( app-doc/doxygen )
  65. kde-frameworks/extra-cmake-modules
  66. virtual/pkgconfig
  67. "
  68. S="${WORKDIR}/${MY_PN}-${PV}"
  69. # "${FILESDIR}/${PN}-5.0.8-fix-conflicts-with-fcitx4.diff"
  70. PATCHES=( )
  71. src_prepare() {
  72. cp "${DISTDIR}/fcitx-data-en_dict-${DV}.tar.gz" src/modules/spell/en_dict-${DV}.tar.gz || die
  73. cmake_src_prepare
  74. }
  75. src_configure() {
  76. local mycmakeargs=(
  77. -DENABLE_TEST=$(usex test)
  78. -DENABLE_COVERAGE=$(usex coverage)
  79. -DENABLE_ENCHANT=$(usex enchant)
  80. -DENABLE_X11=$(usex X)
  81. -DENABLE_WAYLAND=$(usex wayland)
  82. -DENABLE_DBUS=$(usex dbus)
  83. -DENABLE_SERVER=$(usex server)
  84. -DENABLE_KEYBOARD=$(usex keyboard)
  85. -DENABLE_EMOJI=$(usex emoji)
  86. -DENABLE_LIBUUID=$(usex libuuid)
  87. -DENABLE_DOC=$(usex doc)
  88. -DUSE_SYSTEMD=$(usex systemd)
  89. )
  90. cmake_src_configure
  91. }
  92. pkg_postinst() {
  93. xdg_icon_cache_update
  94. xdg_desktop_database_update
  95. }
  96. pkg_postrm() {
  97. xdg_icon_cache_update
  98. xdg_desktop_database_update
  99. }