logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

fcitx-5.0.23.ebuild (2442B)


  1. # Copyright 2021-2022 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit cmake xdg-utils
  5. DV="20121020"
  6. MY_PN="fcitx5"
  7. DESCRIPTION="Fcitx (Flexible Context-aware Input Tool with eXtension) input method framework"
  8. HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx5"
  9. SRC_URI="
  10. https://github.com/fcitx/fcitx5/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz
  11. https://download.fcitx-im.org/data/en_dict-${DV}.tar.gz -> fcitx-data-en_dict-${DV}.tar.gz
  12. "
  13. S="${WORKDIR}/${MY_PN}-${PV}"
  14. LICENSE="LGPL-2.1+"
  15. SLOT="5"
  16. KEYWORDS="~amd64 ~x86"
  17. IUSE="X coverage dbus doc +emoji +enchant +keyboard +libuuid +server systemd test wayland"
  18. REQUIRED_USE="coverage? ( test )"
  19. RESTRICT="!test? ( test )"
  20. DEPEND="
  21. X? (
  22. dev-libs/glib:2
  23. x11-libs/cairo[X]
  24. x11-libs/gdk-pixbuf:2
  25. x11-libs/libxcb[xkb]
  26. x11-libs/libxkbfile
  27. x11-libs/pango[X]
  28. x11-libs/xcb-util
  29. x11-libs/xcb-util-keysyms
  30. x11-libs/xcb-util-wm
  31. )
  32. dev-libs/libfmt
  33. emoji? (
  34. app-i18n/unicode-cldr
  35. dev-libs/expat
  36. )
  37. enchant? ( app-text/enchant:2 )
  38. keyboard? (
  39. app-text/iso-codes
  40. dev-libs/expat
  41. dev-libs/json-c
  42. x11-libs/libxkbcommon[X?]
  43. x11-misc/xkeyboard-config
  44. )
  45. libuuid? ( sys-apps/util-linux )
  46. sys-devel/gettext
  47. systemd? ( sys-apps/systemd )
  48. !systemd? (
  49. dbus? ( sys-apps/dbus )
  50. dev-libs/libevent
  51. )
  52. virtual/libintl
  53. wayland? (
  54. dev-libs/glib:2
  55. dev-libs/wayland
  56. dev-libs/wayland-protocols
  57. dev-util/wayland-scanner
  58. x11-libs/cairo
  59. x11-libs/gdk-pixbuf:2
  60. x11-libs/pango
  61. )
  62. "
  63. RDEPEND="${DEPEND}
  64. "
  65. BDEPEND="
  66. doc? ( app-text/doxygen )
  67. kde-frameworks/extra-cmake-modules
  68. virtual/pkgconfig
  69. "
  70. # "${FILESDIR}/${PN}-5.0.8-fix-conflicts-with-fcitx4.diff"
  71. PATCHES=( )
  72. src_prepare() {
  73. cp "${DISTDIR}/fcitx-data-en_dict-${DV}.tar.gz" src/modules/spell/en_dict-${DV}.tar.gz || die
  74. cmake_src_prepare
  75. }
  76. src_configure() {
  77. local mycmakeargs=(
  78. -DENABLE_TEST=$(usex test)
  79. -DENABLE_COVERAGE=$(usex coverage)
  80. -DENABLE_ENCHANT=$(usex enchant)
  81. -DENABLE_X11=$(usex X)
  82. -DENABLE_WAYLAND=$(usex wayland)
  83. -DENABLE_DBUS=$(usex dbus)
  84. -DENABLE_SERVER=$(usex server)
  85. -DENABLE_KEYBOARD=$(usex keyboard)
  86. -DENABLE_EMOJI=$(usex emoji)
  87. -DENABLE_LIBUUID=$(usex libuuid)
  88. -DENABLE_DOC=$(usex doc)
  89. -DUSE_SYSTEMD=$(usex systemd)
  90. )
  91. cmake_src_configure
  92. }
  93. pkg_postinst() {
  94. xdg_icon_cache_update
  95. xdg_desktop_database_update
  96. }
  97. pkg_postrm() {
  98. xdg_icon_cache_update
  99. xdg_desktop_database_update
  100. }