logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

fcitx-qt-5.0.17.ebuild (1313B)


  1. # Copyright 2021-2022 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit cmake
  5. MY_PN="fcitx5-qt"
  6. DESCRIPTION="Qt library and IM module for fcitx5"
  7. HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx5-qt"
  8. SRC_URI="https://github.com/fcitx/fcitx5-qt/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
  9. LICENSE="BSD LGPL-2.1+"
  10. SLOT="5"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE="dbus only-plugin static-plugin X"
  13. REQUIRED_USE="static-plugin? ( only-plugin )"
  14. DEPEND="
  15. dev-qt/qtcore:5
  16. dev-qt/qtgui:5
  17. dev-qt/qtwidgets:5
  18. x11-libs/libxkbcommon
  19. !only-plugin? ( >=app-i18n/fcitx-5.0.16:5 )
  20. dbus? ( dev-qt/qtdbus:5 )
  21. X? (
  22. x11-libs/libX11
  23. x11-libs/libxcb
  24. )
  25. "
  26. RDEPEND="${DEPEND}"
  27. BDEPEND="
  28. !only-plugin? ( sys-devel/gettext )
  29. kde-frameworks/extra-cmake-modules
  30. virtual/pkgconfig
  31. "
  32. S="${WORKDIR}/${MY_PN}-${PV}"
  33. PATCHES=(
  34. "${FILESDIR}/0001-CMake-Add-option-to-disable-X11-support.patch"
  35. "${FILESDIR}/0002-CMake-Add-option-to-disable-DBus-support.patch"
  36. )
  37. src_configure() {
  38. # gentoo only support qt5 officially, disable qt4 & qt6 for now
  39. local mycmakeargs=(
  40. -DENABLE_DBUS=$(usex dbus)
  41. -DENABLE_QT4=no
  42. -DENABLE_QT6=no
  43. -DENABLE_X11=$(usex X)
  44. -DBUILD_ONLY_PLUGIN=$(usex only-plugin)
  45. -DBUILD_STATIC_PLUGIN=$(usex static-plugin)
  46. )
  47. cmake_src_configure
  48. }