logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

fcitx-anthy-5.0.14.ebuild (790B)


  1. # Copyright 2013-2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit cmake xdg-utils
  5. MY_P="fcitx5-anthy-${PV}"
  6. DESCRIPTION="Japanese Anthy input methods for Fcitx5"
  7. HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx5-anthy"
  8. # verify-sig? ( https://download.fcitx-im.org/fcitx5/fcitx5-anthy/fcitx5-anthy-${PV}.tar.xz.sig )
  9. SRC_URI="https://download.fcitx-im.org/fcitx5/fcitx5-anthy/${MY_P}.tar.xz"
  10. S="${WORKDIR}/${MY_P}"
  11. LICENSE="GPL-2+"
  12. SLOT="5"
  13. KEYWORDS="~amd64 ~ppc64 ~riscv ~x86"
  14. IUSE=""
  15. BDEPEND="virtual/pkgconfig"
  16. DEPEND="
  17. >=app-i18n/fcitx-5.0.6:5
  18. app-i18n/anthy:=
  19. sys-devel/gettext
  20. virtual/libintl
  21. "
  22. RDEPEND="${DEPEND}"
  23. DOCS=()
  24. pkg_postinst() {
  25. xdg_icon_cache_update
  26. }
  27. pkg_postrm() {
  28. xdg_icon_cache_update
  29. }