logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

uxn-9999.ebuild (550B)


  1. # Copyright 2022 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. if [[ "${PV}" = "9999" ]]; then
  5. inherit git-r3
  6. EGIT_REPO_URI="https://git.sr.ht/~rabbits/uxn"
  7. else
  8. KEYWORDS=""
  9. fi
  10. DESCRIPTION="Assembler and emulator for the Uxn stack-machine, written in ANSI C"
  11. HOMEPAGE="https://sr.ht/~rabbits/uxn/"
  12. LICENSE="MIT"
  13. SLOT="0"
  14. DEPEND="
  15. media-libs/libsdl2
  16. "
  17. RDEPEND="${DEPEND}"
  18. src_compile() {
  19. ./build.sh --no-run || die
  20. }
  21. src_install() {
  22. einstalldocs
  23. dobin bin/*
  24. }