logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

arcem-1.50.ebuild (622B)


  1. # Copyright 2024 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit toolchain-funcs
  5. DESCRIPTION="Dave Gilbert's Acorn Archimedes emulator"
  6. HOMEPAGE="https://arcem.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/${PN}/arcem-${PV}-src.zip"
  8. S="${WORKDIR}/arcem-src"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. DEPEND="x11-libs/libX11"
  13. RDEPEND="${DEPEND}"
  14. src_prepare() {
  15. default
  16. # Clean out CFLAGS
  17. sed -i '/ifeq (\$(PROFILE),yes)/,/^$/d' Makefile || die
  18. }
  19. src_compile() {
  20. emake CC="$(tc-getCC)" LD="$(tc-getCC)"
  21. }
  22. src_install() {
  23. einstalldocs
  24. dobin arcem
  25. }