logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

vim-1.24.ebuild (976B)


  1. # Copyright 2019-2021 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. # vim-1.14 can also be found but the first version of vim to work on Unix
  4. # is version 1.22, which I didn’t found.
  5. EAPI=8
  6. DESCRIPTION="Vi IMitation"
  7. HOMEPAGE="https://www.vim.org/ https://ftp.nluug.nl/pub/vim/old/"
  8. SRC_URI="https://ftp.nluug.nl/pub/vim/old/${P}.tar.gz"
  9. SLOT="${PV}"
  10. KEYWORDS="~amd64 ~x86"
  11. LICENSE="public-domain"
  12. S="${WORKDIR}/${P}/src"
  13. src_prepare() {
  14. default
  15. ln makefile.unix makefile || die
  16. sed -r -i \
  17. -e 's/^(DEFS = .*) -DTERMCAP(.*)/\1\2/' \
  18. -e 's/^(DEFS = .*) -DSOME_BUILTIN_TCAPS(.*)/\1\2/' \
  19. -e 's/LIBS = -ltermlib/LIBS =/' \
  20. -e '165s;mkcmdtab;./mkcmdtab;' \
  21. makefile || die
  22. sed -i '28s/#ifdef SYSV/#ifndef SYSV/' unix.c
  23. }
  24. src_install() {
  25. cd ..
  26. newbin vim vim-${PV}
  27. }
  28. pkg_post_install() {
  29. einfo 'You will need to do have VIMINIT="" in your enviroment to prevent a segfault of vim'
  30. }