logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

hare-specification-9999.ebuild (596B)


  1. # Copyright 2022 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit git-r3
  5. DESCRIPTION="Hare programming language specification"
  6. HOMEPAGE="https://git.sr.ht/~sircmpwn/hare-specification"
  7. EGIT_REPO_URI="https://git.sr.ht/~sircmpwn/hare-specification"
  8. LICENSE="CC-BY-ND-4.0"
  9. SLOT="0"
  10. KEYWORDS=""
  11. IUSE=""
  12. BDEPEND="
  13. app-text/texlive[xetex]
  14. dev-texlive/texlive-fontsextra
  15. dev-texlive/texlive-latexextra
  16. "
  17. DOCS=( specification.pdf )
  18. src_compile() {
  19. emake
  20. emake # for the ToC
  21. }
  22. src_install() {
  23. einstalldocs
  24. }