logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

acme-sh-9999.ebuild (1221B)


  1. # Copyright 2019 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. if [ "${PV}" == "9999" ]
  5. then
  6. inherit git-r3
  7. EGIT_REPO_URI="https://github.com/Neilpang/acme.sh"
  8. else
  9. SRC_URI="https://github.com/Neilpang/acme.sh/archive/${PV}.tar.gz -> ${P}.tar.gz"
  10. S="${WORKDIR}/acme.sh-${PV}"
  11. KEYWORDS="~amd64"
  12. fi
  13. DESCRIPTION="pure Unix shell script implementing ACME client protocol"
  14. HOMEPAGE="https://acme.sh/"
  15. LICENSE="GPL-3"
  16. SLOT="0"
  17. IUSE="standalone"
  18. RDEPEND="
  19. net-misc/curl
  20. || ( dev-libs/openssl:0 )
  21. standalone? ( net-misc/socat )
  22. virtual/cron
  23. "
  24. src_install() {
  25. einstalldocs
  26. newdoc dnsapi/README.md README-dnsapi.md
  27. newdoc deploy/README.md README-deploy.md
  28. exeinto /usr/share/acme.sh
  29. doexe acme.sh
  30. for i in dnsapi deploy notify
  31. do
  32. insinto "/usr/share/acme.sh/$i"
  33. doins -r "$i/"*.sh
  34. done
  35. dosym ../share/acme.sh/acme.sh usr/bin/acme.sh
  36. einfo "Recommended way to use this ebuild:"
  37. einfo "- Create a acme user in a new 'certs' group"
  38. einfo "- Create a shared directory owned by acme:certs"
  39. einfo "- Put nginx and other daemons using the certificates into the 'certs' groups and configure them to use the shared directory"
  40. }