logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

julius-4.3.1.ebuild (1104B)


  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils toolchain-funcs
  5. DESCRIPTION="Large Vocabulary Continuous Speech Recognition Engine"
  6. HOMEPAGE="http://julius.sourceforge.jp/"
  7. SRC_URI="mirror://sourceforge.jp/julius/60273/${P}.tar.gz"
  8. LICENSE="julius"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="+alsa oss portaudio pulseaudio sndfile"
  12. REQUIRED_USE="^^ ( alsa oss portaudio pulseaudio )"
  13. RDEPEND="
  14. dev-lang/perl
  15. dev-perl/Jcode
  16. sys-libs/readline:0
  17. sys-libs/zlib
  18. alsa? ( media-libs/alsa-lib )
  19. portaudio? ( media-libs/portaudio )
  20. pulseaudio? ( media-sound/pulseaudio )
  21. sndfile? ( media-libs/libsndfile )"
  22. DEPEND="${RDEPEND}
  23. sys-devel/flex"
  24. pkg_setup() {
  25. tc-export CC CXX
  26. }
  27. src_install() {
  28. default
  29. if ! has ja ${LINGUAS} ; then
  30. rm -r "${ED}"/usr/share/man/ja || die
  31. fi
  32. }
  33. pkg_postinst() {
  34. eerror "IMPORTANT NOTICE"
  35. elog "/usr/bin/jcontrol has been renamed to /usr/bin/jucontrol"
  36. elog "to avoid file collision with dev-java/java-config."
  37. elog "If this creates a problem with applications, file a gentoo bug."
  38. }