logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

firefox-user-js-9999.ebuild (837B)


  1. # Copyright 2018 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit git-r3
  5. DESCRIPTION="Firefox configuration hardening"
  6. HOMEPAGE="https://github.com/pyllyukko/user.js"
  7. SLOT="0"
  8. LICENSE="MIT"
  9. EGIT_REPO_URI="${HOMEPAGE}.git"
  10. src_prepare() {
  11. default
  12. cp "${FILESDIR}/local-settings.js" .
  13. sed -i 's/tests/test/' Makefile || die "Failed changing tests to test"
  14. sed -i '{/all:/ s/test//}' Makefile || die "Failed removing test from ``make all``"
  15. sed -i '{/test:/ s/acorn//}' Makefile || die "Failed removing acorn (unknown command) from test"
  16. }
  17. src_compile() {
  18. default
  19. emake systemwide_user.js
  20. }
  21. src_install() {
  22. insinto /usr/lib/firefox
  23. newins systemwide_user.js mozilla.cfg
  24. insinto /usr/lib/firefox/defaults/pref/
  25. doins local-settings.js
  26. }