logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

woob-qt-9999.ebuild (676B)


  1. # Copyright 2021 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. PYTHON_COMPAT=( python3_{7..9} )
  5. inherit distutils-r1
  6. if [[ "${PV}" == "9999" ]]
  7. then
  8. EGIT_REPO_URI="https://gitlab.com/woob/${PN}.git"
  9. inherit git-r3
  10. else
  11. SRC_URI="https://gitlab.com/woob/${PN}/-/archive/${PV}/${P}.tar.gz"
  12. KEYWORDS="~amd64"
  13. fi
  14. DESCRIPTION="Web outside of Browsers (Qt applications)"
  15. HOMEPAGE="https://gitlab.com/woob/woob-qt"
  16. LICENSE="LGPL-3+"
  17. SLOT="0"
  18. DEPEND="
  19. app-crypt/gnupg
  20. dev-python/PyQt5[${PYTHON_USEDEP},multimedia]
  21. dev-libs/libyaml
  22. dev-python/simplejson[${PYTHON_USEDEP}]
  23. "
  24. RDEPEND="${DEPEND}"