logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

mdevd-0.1.6.3.ebuild (813B)


  1. # Copyright 2024 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit optfeature toolchain-funcs
  5. DESCRIPTION="small daemon managing kernel hotplug events, similarly to udevd"
  6. HOMEPAGE="https://skarnet.org/software/mdevd/"
  7. SRC_URI="https://skarnet.org/software/mdevd/${P}.tar.gz"
  8. LICENSE="ISC"
  9. SLOT="0"
  10. KEYWORDS="~amd64"
  11. IUSE=""
  12. RDEPEND=">=dev-libs/skalibs-2.14.0.0:="
  13. DEPEND="${RDEPEND}"
  14. DOCS=( AUTHORS NEWS README doc/ examples )
  15. src_configure() {
  16. econf \
  17. --with-sysdeps=/usr/$(get_libdir)/skalibs/ \
  18. --enable-shared \
  19. --disable-static
  20. # TODO: --enable-nsss
  21. }
  22. src_compile() {
  23. emake AR=$(tc-getAR) RANLIB=$(tc-getRANLIB)
  24. }
  25. pkg_postinst() {
  26. optfeature "For +/-/& command directives in mdev.conf" dev-lang/execline
  27. }