logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

utils-std-9999.ebuild (843B)


  1. # Copyright 2021-2024 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit git-r3
  5. DESCRIPTION="Collection of commonly available Unix tools"
  6. HOMEPAGE="https://hacktivis.me/git/utils-std"
  7. EGIT_REPO_URI="https://hacktivis.me/git/utils-std.git"
  8. LICENSE="MPL-2.0"
  9. SLOT="0"
  10. IUSE="test static"
  11. RESTRICT="!test? ( test )"
  12. BDEPEND="
  13. app-alternatives/yacc
  14. test? (
  15. dev-libs/atf
  16. dev-util/kyua
  17. dev-util/cram
  18. )
  19. "
  20. src_configure() {
  21. export NO_BWRAP=1
  22. use static && export LDSTATIC="-static"
  23. ./configure PREFIX='/opt/lanodan'
  24. }
  25. src_install() {
  26. emake install DESTDIR="${D}"
  27. # before 50baselayout
  28. newenvd - 40lanodan <<-EOF
  29. PATH="/opt/lanodan/bin:/opt/lanodan/sbin"
  30. ROOTPATH="/opt/lanodan/bin:/opt/lanodan/sbin"
  31. MANPATH="/opt/lanodan/share/man"
  32. EOF
  33. }