logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

streamlink-3.0.3.ebuild (1448B)


  1. # Copyright 1999-2022 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. PYTHON_COMPAT=( python3_{8..9} )
  5. PYTHON_REQ_USE='xml(+),threads(+)'
  6. DISTUTILS_SINGLE_IMPL=1
  7. inherit distutils-r1
  8. DESCRIPTION="CLI for extracting streams from websites to a video player of your choice"
  9. HOMEPAGE="https://streamlink.github.io/"
  10. if [[ ${PV} = 9999* ]]; then
  11. EGIT_REPO_URI="https://github.com/streamlink/${PN}.git"
  12. inherit git-r3
  13. else
  14. SRC_URI="https://github.com/streamlink/${PN}/releases/download/${PV}/${P}.tar.gz"
  15. KEYWORDS="~amd64 ~x86"
  16. fi
  17. LICENSE="BSD-2 Apache-2.0"
  18. SLOT="0"
  19. IUSE="test"
  20. RESTRICT="!test? ( test )"
  21. DEPEND="
  22. $(python_gen_cond_dep '
  23. dev-python/isodate[${PYTHON_USEDEP}]
  24. >=dev-python/lxml-4.6.4[${PYTHON_USEDEP}]
  25. dev-python/pycountry[${PYTHON_USEDEP}]
  26. >=dev-python/pycryptodome-3.4.3[${PYTHON_USEDEP}]
  27. >=dev-python/PySocks-1.5.8[${PYTHON_USEDEP}]
  28. >=dev-python/requests-2.26.0[${PYTHON_USEDEP}]
  29. >=dev-python/websocket-client-1.2.1[${PYTHON_USEDEP}]
  30. ')
  31. "
  32. RDEPEND="${DEPEND}
  33. media-video/ffmpeg
  34. "
  35. BDEPEND="
  36. $(python_gen_cond_dep '
  37. test? (
  38. dev-python/mock[${PYTHON_USEDEP}]
  39. dev-python/requests-mock[${PYTHON_USEDEP}]
  40. >=dev-python/freezegun-1.0.0[${PYTHON_USEDEP}]
  41. dev-python/freezegun[${PYTHON_USEDEP}]
  42. )
  43. ')"
  44. distutils_enable_tests pytest
  45. python_configure_all() {
  46. # Avoid iso-639, iso3166 dependencies since we use pycountry.
  47. export STREAMLINK_USE_PYCOUNTRY=1
  48. }