logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

wpewebkit-2.38.2.ebuild (3149B)


  1. # Copyright 1999-2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. CMAKE_MAKEFILE_GENERATOR="ninja"
  5. PYTHON_COMPAT=( python3_{7..9} )
  6. USE_RUBY="ruby24 ruby25 ruby26 ruby27 ruby30"
  7. inherit cmake python-any-r1 ruby-single
  8. DESCRIPTION="WebKit port optimized for embedded devices"
  9. HOMEPAGE="https://wpewebkit.org/"
  10. LICENSE="LGPL-2+ BSD"
  11. SRC_URI="https://wpewebkit.org/releases/${P}.tar.xz"
  12. SLOT="1.1" # WPE_API_VERSION
  13. KEYWORDS="~amd64"
  14. IUSE="accessibility doc examples experimental gamepad jpeg2k qt +gstreamer sandbox systemd +webdriver +webcrypto webrtc X"
  15. REQUIRED_USE="webrtc? ( gstreamer )"
  16. RDEPEND="
  17. >=x11-libs/cairo-1.16.0:=[X?]
  18. >=media-libs/fontconfig-2.13.0:=
  19. >=media-libs/freetype-2.9.0:=
  20. >=dev-libs/glib-2.44.0:=
  21. >=media-libs/harfbuzz-1.4.2:=[icu(+)]
  22. >=dev-libs/icu-60.2:=
  23. virtual/jpeg:0=
  24. >=media-libs/libepoxy-1.4.0:=
  25. >=dev-libs/libgcrypt-1.7.0:=
  26. net-libs/libsoup:3.0=
  27. >=dev-libs/libxml2-2.8.0:=
  28. media-libs/libpng:=
  29. dev-db/sqlite:3=
  30. media-libs/libwebp:=
  31. gui-libs/libwpe:=
  32. sys-libs/zlib:=
  33. >=dev-libs/libxslt-1.1.7
  34. >=media-libs/woff2-1.0.2
  35. jpeg2k? ( >=media-libs/openjpeg-2.2.0:2= )
  36. webcrypto? (
  37. dev-libs/libtasn1:=
  38. >=dev-libs/libgcrypt-1.7.0:=
  39. )
  40. qt? (
  41. dev-qt/qtcore:5=
  42. dev-qt/qtquickcontrols:5=
  43. dev-qt/qtgui:5=
  44. dev-qt/qttest:5=
  45. >=gui-libs/wpebackend-fdo-1.3.0:=
  46. )
  47. gstreamer? (
  48. >=media-libs/gstreamer-1.16:1.0
  49. >=media-libs/gst-plugins-base-1.16:1.0[egl]
  50. >=media-plugins/gst-plugins-opus-1.16:1.0
  51. >=media-libs/gst-plugins-bad-1.16:1.0
  52. )
  53. webrtc? (
  54. media-plugins/gst-plugins-webrtc:1.0
  55. dev-libs/openssl:=
  56. )
  57. accessibility? (
  58. >=dev-libs/atk-2.16.0:=
  59. app-accessibility/at-spi2-atk:=
  60. )
  61. sandbox? ( sys-apps/bubblewrap )
  62. systemd? ( sys-apps/systemd:= )
  63. gamepad? ( >=dev-libs/libmanette-0.2.4 )
  64. "
  65. DEPEND="
  66. ${RDEPEND}
  67. ${PYTHON_DEPS}
  68. ${RUBY_DEPS}
  69. >=dev-lang/perl-5.10
  70. virtual/perl-JSON-PP
  71. doc? ( >=dev-util/gtk-doc-1.10 )
  72. "
  73. src_configure() {
  74. # Ruby situation is a bit complicated. See bug 513888
  75. local rubyimpl
  76. local ruby_interpreter=""
  77. for rubyimpl in ${USE_RUBY}; do
  78. if has_version -b "virtual/rubygems[ruby_targets_${rubyimpl}]"; then
  79. ruby_interpreter="-DRUBY_EXECUTABLE=$(type -P ${rubyimpl})"
  80. fi
  81. done
  82. # This will rarely occur. Only a couple of corner cases could lead us to
  83. # that failure. See bug 513888
  84. [[ -z $ruby_interpreter ]] && die "No suitable ruby interpreter found"
  85. local mycmakeargs=(
  86. "-DPORT=WPE"
  87. -DENABLE_ACCESSIBILITY=$(usex accessibility)
  88. -DENABLE_BUBBLEWRAP_SANDBOX=$(usex sandbox)
  89. -DENABLE_GAMEPAD=$(usex gamepad)
  90. -DUSE_WOFF2=ON
  91. -DSHOULD_INSTALL_JS_SHELL=ON
  92. -DENABLE_ENCRYPTED_MEDIA=OFF
  93. -DENABLE_EXPERIMENTAL_FEATURES=$(usex experimental)
  94. -DUSE_OPENJPEG=$(usex jpeg2k)
  95. -DENABLE_WPE_QT_API=$(usex qt)
  96. -DENABLE_MINIBROWSER=$(usex examples)
  97. -DENABLE_VIDEO=$(usex gstreamer)
  98. -DENABLE_WEB_AUDIO=$(usex gstreamer)
  99. -DENABLE_WEBDRIVER=$(usex webdriver)
  100. -DENABLE_WEB_CRYPTO=$(usex webcrypto)
  101. -DENABLE_XSLT=ON
  102. -DENABLE_JOURNALD_LOG=$(usex systemd)
  103. -DENABLE_WEB_RTC=$(usex webrtc)
  104. -DENABLE_MEDIA_STREAM=$(usex webrtc)
  105. ${ruby_interpreter}
  106. )
  107. cmake_src_configure
  108. }