logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

opentoonz-1.2.0.ebuild (1999B)


  1. # Copyright 1999-2018 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit cmake-utils
  5. DESCRIPTION="An open-source full-featured 2D animation creation software"
  6. HOMEPAGE="https://opentoonz.github.io/"
  7. SRC_URI="https://github.com/opentoonz/opentoonz/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="BSD CC0-1.0 libtiff"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. #IUSE="system-lzo system-superlu"
  12. IUSE=""
  13. RDEPEND="
  14. >=dev-libs/boost-1.55.0:=
  15. app-arch/lz4:=
  16. dev-libs/lzo:2=
  17. dev-qt/linguist-tools:5
  18. dev-qt/qtcore:5
  19. dev-qt/qtgui:5
  20. dev-qt/qtmultimedia:5[widgets]
  21. dev-qt/qtnetwork:5
  22. dev-qt/qtopengl:5
  23. dev-qt/qtprintsupport:5
  24. dev-qt/qtscript:5
  25. dev-qt/qtsvg:5
  26. dev-qt/qtwidgets:5
  27. dev-qt/qtxml:5
  28. media-libs/freeglut:=
  29. media-libs/freetype:2=
  30. media-libs/glew:=
  31. media-libs/libmypaint
  32. media-libs/libpng:=
  33. media-libs/libsdl2:=
  34. sci-libs/superlu:=
  35. virtual/libusb:1=
  36. "
  37. DEPEND="${RDEPEND}"
  38. CMAKE_USE_DIR="${S}"/toonz/sources
  39. src_configure() {
  40. local mycmakeargs=(
  41. -DTIFF_LIBRARY="${S}/thirdparty/tiff-4.0.3/libtiff/.libs/libtiff.a"
  42. -DWITH_SYSTEM_LZO=ON
  43. -DWITH_SYSTEM_SUPERLU=ON
  44. -DCMAKE_SKIP_RPATH=ON
  45. )
  46. # The upstream uses their own modified libtiff
  47. # See: https://github.com/opentoonz/opentoonz/blob/master/doc/how_to_build_linux.md#building-libtiff
  48. -DCMAKE_SKIP_RPATH=ON
  49. cd thirdparty/tiff-4.0.3 || die
  50. econf \
  51. --with-pic \
  52. --disable-jbig \
  53. --enable-static \
  54. --disable-shared
  55. cmake-utils_src_configure
  56. }
  57. src_compile() {
  58. cd "${S}"/thirdparty/tiff-4.0.3 || die
  59. emake
  60. cmake-utils_src_compile
  61. }
  62. pkg_postinst() {
  63. elog "It is supposedly optional but some files are"
  64. elog "actually required to run the executable properly."
  65. elog
  66. elog "The .config/OpenToonz/ directory in your home folder"
  67. elog "will contain your settings, work and other files."
  68. elog
  69. elog "We need to create it from the command-line:"
  70. elog
  71. elog "$ mkdir -p \$HOME/.config/OpenToonz"
  72. elog "$ cp -r /usr/share/opentoonz/stuff/ \$HOME/.config/OpenToonz/"
  73. }