logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

love-9999.ebuild (1206B)


  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit base games
  5. if [[ ${PV} == 9999* ]]; then
  6. inherit autotools mercurial
  7. EHG_REPO_URI="https://bitbucket.org/rude/${PN}"
  8. SRC_URI=""
  9. KEYWORDS=""
  10. else
  11. SRC_URI="https://www.bitbucket.org/rude/${PN}/downloads/${P}-linux-src.tar.gz"
  12. KEYWORDS="~amd64 ~x86"
  13. fi
  14. DESCRIPTION="A framework for 2D games in Lua"
  15. HOMEPAGE="https://love2d.org/"
  16. LICENSE="ZLIB"
  17. SLOT="0"
  18. IUSE=""
  19. RDEPEND="dev-games/physfs
  20. dev-lang/lua:*[deprecated]
  21. media-libs/devil[mng,png,tiff]
  22. media-libs/freetype
  23. media-libs/libmodplug
  24. media-libs/libsdl[joystick,opengl]
  25. media-libs/libvorbis
  26. media-libs/openal
  27. media-sound/mpg123
  28. virtual/opengl"
  29. DEPEND="${RDEPEND}
  30. media-libs/libmng
  31. media-libs/tiff"
  32. DOCS=( "readme.md" "changes.txt" )
  33. src_prepare() {
  34. if [[ ${PV} == 9999* ]]; then
  35. sh platform/unix/gen-makefile || die
  36. cp platform/unix/Makefile.am . || die
  37. cp platform/unix/configure.ac . || die
  38. mkdir platform/unix/m4 || die
  39. eautoreconf
  40. fi
  41. }
  42. src_install() {
  43. base_src_install
  44. if [[ "${SLOT}" != "0" ]]; then
  45. mv "${ED}${GAMES_BINDIR}"/${PN} \
  46. "${ED}${GAMES_BINDIR}"/${PN}-${SLOT} || die
  47. fi
  48. }