logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

love-0.8.0.ebuild (1166B)


  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit games
  5. if [[ ${PV} == 9999* ]]; then
  6. inherit autotools mercurial
  7. EHG_REPO_URI="https://bitbucket.org/rude/${PN}"
  8. SRC_URI=""
  9. KEYWORDS=""
  10. else
  11. SRC_URI="https://www.bitbucket.org/rude/${PN}/downloads/${P}-linux-src.tar.gz"
  12. KEYWORDS="~amd64 ~arm ~ppc ~x86"
  13. fi
  14. DESCRIPTION="A framework for 2D games in Lua"
  15. HOMEPAGE="https://love2d.org/"
  16. LICENSE="ZLIB"
  17. SLOT="0"
  18. IUSE=""
  19. RDEPEND="dev-games/physfs
  20. dev-lang/lua:*[deprecated]
  21. media-libs/devil[mng,png,tiff]
  22. media-libs/freetype
  23. media-libs/libmodplug
  24. media-libs/libsdl[joystick,opengl,video]
  25. media-libs/libvorbis
  26. media-libs/openal
  27. media-sound/mpg123
  28. virtual/opengl"
  29. DEPEND="${RDEPEND}
  30. media-libs/libmng
  31. media-libs/tiff"
  32. src_prepare() {
  33. if [[ ${PV} == 9999* ]]; then
  34. sh platform/unix/gen-makefile || die
  35. mkdir platform/unix/m4 || die
  36. eautoreconf
  37. fi
  38. epatch "${FILESDIR}"/${P}-freetype2.patch
  39. }
  40. src_install() {
  41. DOCS="readme.md changes.txt" \
  42. default
  43. if [[ "${SLOT}" != "0" ]]; then
  44. mv "${ED}${GAMES_BINDIR}"/${PN} \
  45. "${ED}${GAMES_BINDIR}"/${PN}-${SLOT} || die
  46. fi
  47. }