logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

sys-0.11.0.ebuild (654B)


  1. # Copyright 2023 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. EGO_PN="golang.org/x/sys"
  5. DESCRIPTION="supplemental Go packages for low-level interactions with the operating system"
  6. HOMEPAGE="https://golang.org/x/sys"
  7. SRC_URI="https://github.com/golang/sys/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
  8. S="${WORKDIR}"
  9. LICENSE="BSD"
  10. SLOT="0"
  11. KEYWORDS="~amd64"
  12. src_install() {
  13. mkdir -p "$(dirname "${ED}/usr/lib/go-gentoo/src/${EGO_PN}")" || die
  14. cp -r "${P}" "${ED}/usr/lib/go-gentoo/src/${EGO_PN}" || die
  15. test -f "${ED}/usr/lib/go-gentoo/src/${EGO_PN}/go.mod" || die
  16. }