logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

go_path-0.ebuild (398B)


  1. # Copyright 2023 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. DESCRIPTION="Define GOPATH to /usr/src/go to install sources of Go libraries"
  5. HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
  6. LICENSE="CC0-1.0"
  7. SLOT="0"
  8. KEYWORDS="~amd64"
  9. S="${WORKDIR}"
  10. src_install() {
  11. newenvd - 99gopath <<< "GOPATH=/usr/src/go"
  12. }