logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

unar-1.10.1.ebuild (1174B)


  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit toolchain-funcs
  5. DESCRIPTION="unpacker for various archiving formats, e.g. rar v3"
  6. HOMEPAGE="https://unarchiver.c3.cx/"
  7. SRC_URI="https://unarchiver.c3.cx/downloads/${PN}${PV}_src.zip"
  8. LICENSE="LGPL-2.1"
  9. SLOT="0"
  10. KEYWORDS="~amd64"
  11. IUSE=""
  12. RDEPEND="gnustep-base/gnustep-base
  13. dev-libs/icu:=
  14. sys-libs/zlib
  15. app-arch/bzip2"
  16. DEPEND="${RDEPEND}
  17. >=gnustep-base/gnustep-make-2.6.0[native-exceptions]
  18. || (
  19. sys-devel/gcc[objc]
  20. sys-devel/clang
  21. )"
  22. S="${WORKDIR}/The Unarchiver/XADMaster"
  23. src_prepare() {
  24. # avoid jobserver warning, upstream bug:
  25. # https://bitbucket.org/WAHa_06x36/theunarchiver/issues/918/dont-call-make-from-makefile
  26. sed -i -e 's:make:$(MAKE):g' Makefile.linux
  27. }
  28. src_compile() {
  29. emake -f Makefile.linux \
  30. AR="$(tc-getAR)" \
  31. CC="$(tc-getCC)" \
  32. CXX="$(tc-getCXX)" \
  33. OBJCC="$(tc-getCC)" \
  34. CFLAGS="${CFLAGS}" \
  35. CXXFLAGS="${CXXFLAGS}" \
  36. OBJCFLAGS="${CFLAGS}" \
  37. LD="$(tc-getCXX)" \
  38. LDFLAGS="-Wl,--whole-archive -fexceptions -fgnu-runtime ${LDFLAGS}"
  39. }
  40. src_install() {
  41. dobin {ls,un}ar
  42. doman ../Extra/{ls,un}ar.1
  43. }