logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

mimic1-9999.ebuild (689B)


  1. # Copyright 2019 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit autotools git-r3
  5. DESCRIPTION="Mycroft's TTS engine, based on CMU's Flite (Festival Lite)"
  6. HOMEPAGE="https://mimic.mycroft.ai/"
  7. EGIT_REPO_URI="https://github.com/MycroftAI/mimic1.git"
  8. LICENSE="BSD MIT public-domain freetts BSD-2 Apache-2.0"
  9. SLOT="0"
  10. IUSE="alsa portaudio pulseaudio oss"
  11. DEPEND="
  12. dev-libs/libpcre2
  13. dev-libs/hts_engine
  14. alsa? ( media-libs/alsa-lib )
  15. portaudio? ( media-libs/portaudio )
  16. pulseaudio? ( media-sound/pulseaudio )
  17. "
  18. RDEPEND="${DEPEND}"
  19. BDEPEND="virtual/pkgconfig"
  20. src_prepare() {
  21. default
  22. sed -i 's/-Werror//' Makefile.am
  23. eautoreconf
  24. }